Diego Santos

Vocês anseiam pelo dia em que homens serão homens e escreverão seus próprios devices drivers?

Fedora 9 Sulphur maio 24, 2008

Filed under: Fedora — diegosantos @ 5:36 am
Tags: ,

Olá galera!

Fedora 9 Sulphur lançado, muito a se dizer ou nada? Para todos aqueles que deram uma pesquisada na web, existem muitas boas língua falando da nova versão do “OS comunidade” da Red Hat Inc.

Uso Fedora a dois anos e meio, sou um apaixonado pela maneira como o projeto Fedora apoia o código aberto.

O Fedora 9 se tornou mais simples, mais fácil de se trabalhar. Não tive, por enquanto que procurar nada para instalar no meu sistema que estivesse fora do PackageKit ( excelente!). A comodidade está se tornando um forte para essa distro, mas continuamos com todo o poder sobre o nosso OS.

Para mim que sou programador web, continuo sem ter nada a dizer contra. A inclusão do Firefox 3.0 ainda em fase beta não acarretou em problema algum, aliás louvores sejam dados ao pessoal do Firefox. Fora isso tudo roda redondinho, zend framework, php, postgresql, apache. Não tive ainda a oportunidade de testar o KDE 4, mas o projeto gnome continua muito bom.

O Projeto Fedora provou mais um vez que são capazes de prover um Sistema Operacional de Código Aberto, com excelente qualidade. Fedora tem se tornado uma distro muito poderosa.

… Mas como nada é perfeito.

Ao acrescentar alguns repositórios ao meu yum.repos.d, me lembrei em adicionar o repositório da macromedia ( leia-se Adobre ) por causa do flash-plugin. Instalei-o sem problemas:

[Diego@localhost home]$ su
Password:
[root@localhost home]# yum -y install flash-plugin
Loaded plugins: refresh-packagekit

Ótimo, mas quando fui ouvir algumas músicas no player SeeqPod, ops! Eis o problema, tudo funcionava, menos o audio.  O mais estranho que tudo estava certinho, ouvi um pouco de reggae no computador ( ogg vorbis) logo que instalei o Sulphur. Reinstalei o plugin umas duas vezes, mas nada se resolveu.

Foi então que recorri ao Google.

Bom o que aconteceu foi o seguinte

Já que o novo Flash não funciona com o driver de som OSS e apenas com ALSA. Posto aqui como fiz para resolver esse problema. Essa solução é simples e pode ser encontrada em outros blogs na internet, não tenho mérito algum sobre ele.

Primeiro precisamos instalar algumas dependências para um a compilação de uma lib que a própria adobe disponibilizou.

# yum -y install openssl* icu* libicu* oss* gcc

Após isso já podemos compilar o arquivo : libflashsupport.c .

# gcc -shared -O2 -Wall -Werror -licuuc -lssl flashsupport.c -o libflashsupport.so

Bom, a compilação não deverá apresentar nenhuma saída anormal ( hehe ). Se assim ocorreu, reinicie seu

Firefox 3 Beta 5 e pronto.

Até Breve!

Anúncios